FAQ

The frequently asked questions in Data Integration Platform

What are the authentication support provided in Data Integration Platform?

How to change a user password?

For Basic authentication, Data Integration Platform has the direct support to change the password.

For Kerberos authentication, the password can be changed in Active Directory.

For User Management Server authentication, follow the below steps to change the password for the user.

Step 1:
Navigate to User Management Server interface

Step 2:
Open User profile details

Step 3:
Click change password button to change / update password.



How to solve “Unable to validate the access token” error?

Cause:

This is due to previous login session was not cleared in your browser.

Solution:

Clear the browser cache or session and reload the link.

How to solve “Unauthorized access for a user” error?

This message will be shown when user doesn’t have permission to view Data Integration user interface. To resolve this, contact your application administrator to provide appropriate permission.

Steps to add view user interface permission

  1. Login as admin, navigate to security page.

  2. Select manage policies for a user who need access into Data Integration.

  3. Add policy for “View the user interface”.

  4. Once the policy set, the user can access the User Interface.

  5. For accessing other resources, user need corresponding permission. For more details, refer https://help.syncfusion.com/data-integration/security/user-and-policy-management

How to import groups from Syncfusion User management Server?

No, Data Integration Platform doesn’t have support for importing groups from Syncfusion User Management Server. So, users need to create groups separately even though same group available in Syncfusion User Management Server.

How to add more than one admin account?

Create a new user for admin and add all policies to the user. We recommend to create group for administrators and add all policies to that group. Users who belong to that group will be admin for Data Integration.

If there is only one admin account and it was deleted by accident. In this case, you need to go to Data Integration platform installed location and navigate to “\SDK\NIFI\conf” folder. Delete the users.xml and authorizations.xml file then restart the Data Integration service using Data Integration Manager. This will reset the users and policies altogether. You need to create users/groups again then define policies.

User Management Server stopped unexpectedly. How to start it again?

You can find shortcut on desktop to start and open User Management Server in browser. Double click the same to open the User Management Server.
If shortcut is not available in desktop, navigate to User Management installed location and run any one of the following application (exe) based on the need.

  • For IISExpress - “C:\Program Files (x86)\Syncfusion\UMS\Infrastructure\StartUserManagementServerIISExpress\UserManagementServerIISExpress.exe”.
  • For IIS – “C:\Program Files (x86)\Syncfusion\UMS\Utilities\StartUserManagementServerIIS\UserManagementServerIIS.exe”.

Cannot View/Download Flow data. How to solve it?

This is due to popup blocked by your browser, enable popup for Data Integration Platform in your browser settings. Below screenshot represents the option to enable popup in Google Chrome browser. After enabled popup for Data Integration Platform, try again to view/download the data.



How to change the port number for Data Integration Platform?

To change the port number for Data Integration Platform, Stop the Data Integration Service using Data Integration Service Manager and do the following steps.

  • Navigate to “\Utilities\SyncfusionDataIntegrationAgent” in Data Integration Platform installed location and edit the DataIntegrationAgent.xml file and update the port number in “Portnumber\number” property.

  • Navigate to “Utilities\SyncfusionDataIntegrationManager” in Data Integration Platform installed location and update the property “DataIntegrationService\port” in DataIntegrationManager.xml file with relevant port number.

  • Navigate to “\SDK\NIFI\conf” in Data Integration Platform installed location and edit the nifi.properties file by changing the value of nifi.web.https.portproperty with relevant port number.

  • After completing the above steps start the Data Integration service using Data Integration Service Manager.

  • Alternatively, you can also change nifi.properties file via Data Integration web interface. Click “Configuration” option under menu and edit values for nifi.properties file and restart application as shown.

  • For Data Integration configured with User Management Server, it requires port number changes in application URL registered in User Management Server.

How to get client ID and client secret for registered application?

  • You must register Data Integration Platform application in Syncfusion User Management Server.

  • Select HTTPS and add application URL for Data Integration Platform. Enable “allow access to all users” option.

  • Once application is registered successfully. Click the registered application name.

  • Under general tab, you can find client id and client secret.

How to solve “400 unknown version” error in the ExecuteSalesforceQuery Salesforce processor?

Check the following items while entering query in the SOQL Query property.

  • Replace space in between your SOQL query with + sign (so concatenate all your SOQL query with + sign).

  • Remove unwanted spaces before and after the SOQL query.

These are the possibilities for “400 unknown version” error in the ExecuteSalesforceQuery processor.

Note:For configuring SalesforceControllerService, refer to the link: https://help.syncfusion.com/data-integration/controllerservices/salesforcecontrollerservice