Essential Studio Upgrade Guide

Choose which Essential Studio platform you want to upgrade to a newer version.

Essential JS 1 is the first-generation JQuery based JavaScript UI framework from Syncfusion that was initially released in July 2013. This framework has been in active development for more than four years, and it is feature rich and mature. It also includes support for all popular browsers including older browsers like IE8. We will continue to develop, maintain and support this version for several more years. However, please note that new feature development will only occur in Essential JS 1 if an equivalent control is not yet available in Essential JS 2.

Starting with the Volume 4 2017 release, we have also shipped a beta version of the second generation of the Essential JS library (Essential JS 2). This new library has several advantages over the first-generation library as it has been built from the ground up to be more modular, lightweight, responsive, fast, and has no external dependencies. Nevertheless, it only supports modern browsers starting from IE11 and currently only includes a subset of the controls available in Essential JS 1. Please note that we will ensure that any control in Essential JS 2 will have feature parity with its equivalent in Essential JS 1 before it is officially released.

Here are some guidelines for choosing between these two frameworks.

Existing applications
• Continue to use Essential JS 1 unless you need access to a new feature or control exclusively available in Essential JS 2. We will also be happy to provide any required assistance for migration. • Selectively use controls from Essential JS 2.

New applications
• We recommend using Essential JS 2 unless a control is exclusively available in Essential JS 1.

Please create a support ticket if you need any additional details.