System Requirements for ASP.NET Core

30 Jun 20211 minute to read

The system requirements for using our Syncfusion ASP.NET Core platform are as follows

Operating Systems

  • Windows 7 SP1 and later
  • Windows 8.1
  • Windows 10 Version 1607 and later
  • Windows Server 2008 R2 SP1 (Full Server or Server Core)
  • Windows Server 2012 SP1 (Full Server or Server Core)
  • Windows Server 2012 R2 (Full Server or Server Core)
  • Windows Server 2016 (Full Server, Server Core, or Nano Server)
  • Mac OS X 10.11, 10.12*
  • Red Hat Enterprise Linux 7
  • Ubuntu 14.04, 16.04, 17

Hardware Environment

  • Processor: x86 or x64
  • RAM : 512 MB (minimum), 1 GB (recommended)
  • Hard disc: up to 3 GB of free space may be required

Development Environment

  • Microsoft Visual Studio 2015 Update 3 (minimum) , 2017 version latest (15.6.4), 2019, 2022.
  • .NET Framework : Minimum .NET 4.5.1 upto .NET 4.7 .
  • Command Line (Optional. Necessary for command line deployment)
  • Visual Studio Code (optional text-editor)
  • SQL Server 2008 Express (optional)
  • .NET Core 3.1

Browser support and Required Polyfills

Browser support

Syncfusion Essential JS Component support modern browsers. This include the below versions.

Chrome Firefox Opera Edge IE Safari iOS Android Windows Mobile
Latest Latest Latest 13 + 11 + 9 + 9 + 4.4 + IE 11 +

Required Polyfills

The below polyfills are required to run Essential JS components in each browser.

Browser Polyfills
Chrome(latest), Firefox(latest), Opera(latest), Edge, Safari 9+ NONE
IE 11 ES6 Promise